Chrome 50 und Portable Chrome 50

artikel_chromeGoogle Chrome ist 50. Zumindest in finalen Versionen. Die steht nämlich ab sofort zur Verfügung – für Linux, Windows, Android und auch OS X. Google hat wie so häufig tausende Dollar an die Finder von insgesamt 20 Sicherheitslücken ausgeschüttet, die nicht nur die Desktop-Versionen betrafen, sondern auch Android. Falls noch von euch eingesetzt: laut Log wird Windows Vista und Windows XP nun nicht mehr unterstützt. Die Version 50 sollte so bei euch eingetrudelt sein, bei der von uns bereitgestellten portablen Version sieht das natürlich etwas anders aus.

Leider will aus mir derzeit nicht bekannten Gründen der Updater nicht mehr funktionieren, wahrscheinlich hat Google die Download-URLs für die jeweiligen Pakete geändert. Das führt derzeit dazu, dass ihr das portable Paket herunterladen müsst und in diesem entweder das leere Profil nutzt oder dieses gegen das bislang von euch genutzte austauscht. Download Portable Google Chrome 50 für Windows.

Gefällt dir der Artikel? Dann teile ihn mit deinen Freunden.

Hallo, ich bin Carsten! Baujahr 1977, Dortmunder im Norden, BVB-Getaufter und Gründer dieses Blogs. Auch zu finden bei Twitter, Google+, Facebook, Instagram und YouTube. PayPal-Kaffeespende. Mail: carsten@caschys.blog

37 Kommentare

  1. Caschy, danke für die Rückmeldung hinsichtlich des Standes mit dem Updater! 🙂

  2. Unter Einstellungen>Datenschutz>“Vervollständigungsdienst zum schnelleren Laden von Seiten verwenden“ kann doch die Preloadfunktion deaktiviert werden

  3. Ich für meinen Teil bin aktuell sehr zufrieden mit dem neuen Vivaldi Browser. Dieser ist in meinen Augen der deutlich bessere „Chrome“ und bietet einiges an Funktionen die ich bisher sowohl bei Firefox als auch Chrome vermisst habe.

    Und vielleicht für einige Mac Nutzer noch interessant, Vivaldi funktioniert in Verbindung mit Mausgesten auch unter OS X einwandfrei, und hat nicht diesen lästigen Rechtsklick Bug (dass man doppelt klicken muss fürs Kontextmenü) den Chrome in Verbindung mit Mausgesten unter OS X immer noch hat.

  4. Markus Maier says:

    @Ekkehart: Danke! Der Heise-OP hat sich auf eine gleichlautende Antwort inzwischen positiv zurückgemeldet 🙂

  5. da der Updater ja zurzeit nicht funktioniert , kannst du auch ein portable mit der neusten Beta erstellen?

  6. also ich meinte die beta 51 die ja demnächst erscheint

  7. Meine Chrome-App auf Android 6.0 ist Version 49.0.2623.105 – ebenso die im Play Store.

  8. Star Craftler says:

    also bei mir hat Chrome gestern echt ausgesetzt …. hatte erst nen MBR Fehler … dann wolte Chrome updaten … gemacht … konnte nicht syncen … war echt scheisse 😀 ….

  9. Chrome User says:

    Guten Tag Herr Knobloch, erlauben Sie mir bitte die Nachfrage, weshalb die 64 Bit Version des Chrome Browsers in der Portable Version von Ihnen nicht angeboten wird?

    Vielen Dank.

  10. Gut zu wissen, dass ich mit dem Updater.exe-Problem nicht alleine bin. Hoffentlich kommt da ein Update bald zu. 🙂

  11. zitronius says:

    Der Updater zeigt plötzlich KEINE Fehlermeldung mehr an, sagt aber fälschlicherweise „keine Updates gefunden“.
    Seit 6 Tagen gibt es aber eine neuere Version: „The stable channel has been updated to 50.0.2661.87“ laut http://googlechromereleases.blogspot.com/2016/04/stable-channel-update_20.html
    Im Downloadbereich hier befindet sich noch die Vorversion „50.0.2661.75“ – findet der Updater deswegen die neuere Version nicht?

  12. Novecento says:

    Der Updater findet leider immer noch keine Updates. 🙁

  13. zitronius says:

    Wie wär’s mal mit ’nem neuen Updater ? 💡
    Als Fortsetzung von http://stadt-bremerhaven.de/updater-fuer-portable-google-chrome/ 😉
    Seite der hier downloadbaren Version 50.0.2661.75 wurden bereits die Versionen 50.0.2661.87 / 50.0.2661.94 / 50.0.2661.102 von Google als „stable update for windows“ vom Stapel gelassen!! 😯

  14. @zitronius:
    google doch mal nach Chrome Portable Updater
    da findest du bestimmt massenhaft Wissenswertes.

    @Caschy:

    Du schreibst:
    „Leider will aus mir derzeit nicht bekannten Gründen der Updater nicht mehr funktionieren, wahrscheinlich hat Google die Download-URLs für die jeweiligen Pakete geändert. Das führt derzeit dazu, dass ihr das portable Paket herunterladen müsst und in diesem entweder das leere Profil nutzt oder dieses gegen das bislang von euch genutzte austauscht.“

    Der Fehler ist noch nicht behoben.
    Ich hab Chrome in Chrome49 umbenannt und dann den Installer von PortableApps.com benutzt (neuen Ordner Chrome erstellen lassen) und durch Anmeldung bei Chrome meine Einstellungen synchronisiert.
    Erstaunlich für mich: Mein alter Ordner = 975 MB, der neue, nach Synchronisation + Neustart + 1 Tag Warten/Nachtröpfeln der Sync = 449 MB [immer noch leicht steigend].

  15. Zum Updater:

    Das Problem liegt in der angegebenen URL. Dort wird dem Google-Server mitgeteilt das das OS welches den Download versucht ein Win XP Sp3 ist.

    Beim Updater ist die Update.au3, also das AutoIt-Skript aus dem der Updater erstellt wurde dabei. Das kann man selbst abändern.

    Die nötigen Änderungen sehen so aus (wer „diff“ und „patch“ beherrscht sollte damit klarkommen, alle anderen können hoffentlich durch lesen und mit Hilfe eines Texteditors das Skript ändern. Zusätzlich wird AutoIt [ggf. mal Google fragen was das ist] zur Ausführung benötigt.)

    $ diff Updater.au3 UpdaterW7.au3
    105c105
    < $data='‘

    > $data=“
    108c108
    < $data='‘

    > $data=“
    111c111
    < $data='‘

    > $data=“
    251c251,252
    FileCopy( @ScriptDir &“\Update\extracted\Chrome-bin\chrome.exe“, @ScriptDir&“\Chrome\“ ,1 )
    > FileCopy( @ScriptDir &“\Update\extracted\Chrome-bin\wow_helper.exe“, @ScriptDir&“\Chrome\“ ,1 )
    290c291

    Und bevor Fragen aufkommen: NEIN, ich werde keine neue .exe zur Verfügung stellen!

  16. @Caschy: Mist, irgenwie mag deine Anzeige meine diff-Ausgaben nicht darstellen.

    Also hier nochmal in Kurzversion:

    Alle Vorkommen von:
    platform=“win“ version=“5.1″ sp=“Service Pack 3″
    ersetzen durch
    platform=“win“ version=“6.1″ sp=“Service Pack 1″

    Und in Zeile 251 noch das
    FileCopy( @ScriptDir &“\Update\extracted\chrome.exe“, @ScriptDir&“\Chrome\“ ,1 )
    ersetzen durch
    FileCopy( @ScriptDir &“\Update\extracted\Chrome-bin\chrome.exe“, @ScriptDir&“\Chrome\“ ,1 )
    FileCopy( @ScriptDir &“\Update\extracted\Chrome-bin\wow_helper.exe“, @ScriptDir&“\Chrome\“ ,1 )

    Dann sollte alles wieder funktionieren

    (Alle Angaben ohne Gewähr)

  17. @nurich: Danke für deine Hilfe, ich werde das sicher nicht mal eben einbauen können. Hatte damals Hilfe von jemandem, der damals schwer krank war und irgendwann riss der Kontakt leider ab.

  18. @NurIch +Caschy :

    Danke.
    Findet sich unter ‚uns‘ Lesern ein Kundiger, der das umsetzt + verfügbar macht?

  19. chuckbroozeg says:

    @ bat ich hab mir gerade mal exe2auth.exe v6 runtergeladen von
    https://docs.google.com/file/d/0Bytry-3HMDAdTDZSZFpaRVBOQzQ/view?pref=2&pli=1
    und da einfach die updater exe reingezogen.

    dadurch hat er mir ein au3 script extrahiert.

    das script hab ich im notepad++ geladen und wie von nurich beschrieben die windows version ersetzt

    also xp durch windows7 weil ja chrome kein xp mehr unterstützt.

    von
    platform=“win“ version=“5.1″ sp=“Service Pack 3″
    nach
    platform=“win“ version=“6.1″ sp=“Service Pack 1″

    dann autoit installiert und das script damit ausgeführt.

    das hat zur folge das er mir gerade auf Version 51.0.2704.63 updated.

    an den copy ordnern hab ich nix gemacht oder getestet. von daher werd ich das natürlich auch nicht publizieren. aber nachstellen sollte sich das problemlos lassen.

  20. chuckbroozeg says:

    Nachtrag die 7za.exe muss im Ordner liegen und wird immer wieder gelöscht.

    Ich hab das auch doch mal mit autoit zu ner exe gemacht die unter Vorbehalt zumindest bei mir funktioniert.

    Da ich keinen eigenen Webspace habe und von Clouds die Finger lasse hab ichs auf uploaded hochgeladen.
    http://uploaded.net/file/c5q5if9f

    Empfehle aber es doch selber zu machen :-D.

  21. chuckbroozeg says:

    Wie gesagt ich hab da nur die Windows Version aktualisiert. Die von NurIch ewähnten CopyBefehle waren so nicht zu finden bzw schon in seinem aktualisierten Zustand allerdings nicht an Zeile 251. Könnte aber auch am decompilieren liegen. Ich weiss ja nicht welche ScriptDatei (*.au3) er/sie zur verfügung hatten.

    Große Tests hab ich auch nicht gemacht (musste dann übermüdet zur Arbeit fahren ^^). Ausser natürlich um herauszufinden das die 7za.exe zur Verfügung stehen muss und das die im updater rein kompiliert war :-D. Die ist aber nun auch in der neuen von mir mit drin.

    Wäre schön wenn ein zwei Leute die es vielleicht ausprobieren Rückmeldung geben ob es bei ihnen auch funktioniert oder auch nicht. Das man oder irgendwer der sich wirklich damit auskennt das ganze übernimmt.

    Existiert eigentlich irgendwo öffentlich zugänglich das original verwendete au3 script?

  22. @chuckbroozeg + caschy:

    Erstmal DANKE!

    Bei mir klappt das Update vorerst nicht.
    Bin mit Version 50.0.2661.102 m unterwegs – und dabei bleibt’s auch nach dem Durchlauf des Updaters, der nach dem schwarzen Fenster auf Chrome portable 51.0.2704.63 updaten soll, was die neueste stabile Version ist, seit 2 Tagen.

    Werde versuchen, mir das Archiv anderswohin zu kopieren und selber zu entpacken, was aber schwierig ist, weil es sofort von selbst gelöscht wird – nach dem Updatevorgang.

    Bei VirusTotal bemeckern 3 die Chrome Updater_Win7Sp1Basis.exe, was aber wohl ignoriert werden kann):

    McAfee-GW-Edition BehavesLike.Win32.Generic.tc
    Qihoo-360 HEUR/QVM10.1.0000.Malware.Gen
    Zoner Trojan.Generic

  23. Hab in Everything nach 51.0.2704.63 gesucht, in den Tiefen meines PCs u.a. 51.0.2704.63_chrome_installer[1].175980F911955B04F32D13236E884D87F29489B2&key=cms1 gefunden, in 51.0.2704.63_chrome_installer.zip umbenannt und entpackt.

    Wurde zu chrome.7z. Das durch entpacken zum Ordner Chrome-bin. Darin Ordner 51.0.2704.63 + Dateien chrome.exe und wow_helper.exe.

    Im Ordner sind offenbar die Binaries von Chrome 51.0.2704.63, startbar durch die chrome.exe.

  24. Hab nochmal das oben in Caschys Beitrag verlinkte ‚Portable Google Chrome 50 für Windows‘ gedownloadet/entpackt + von Caschy heute 10:21 verlinkte ‚Chrome Updater_Win7Sp1Basis.exe‘ dazugefügt + gestartet. Und jetzt lief das Update auf 51.0.2704.63 problemlos.

    Super. DANKE!

  25. ChuckBROOZeG says:

    @bat ja manche Virenscanner haben wohl mit au3 Sachen so ihre Probleme und nehmen die Pauschal mit generic in Vorverdacht. Ist quasi das gleiche vorgehen wie bei in sich selbst gepackte Exen auch wenn dies nur aus Platzgründen gemacht wird.

    Ich hab ja geschrieben was ich gemacht habe. Das beste wäre ja das original au3 zu haben und dann anzupassen :-D.

    Ich hab mir den Patchvorgang nun ein wenig genauer angeschaut. Der Updater legt im Chome/updates Ordner selbst Hinweise des Updatezeitpunkts und der aktuellen Version ab.

    Der Haken im Updater scheint einfach zu bedeuten das er diesen Ordner ignoriert.

    Sobald du den Ordner Chrome/Updates löscht oder leerst lädt er egal welche Version vorhanden ist die neueste nach.

    Ich hab mir mal den Spass gegeben in einem Testordner erst den originalen Updater laufen zu lassen ohne das der Chrome überhaupt da war. Dann hat er logischerweise den letzten auf WindowsXP laufenden Chrome zgezogen und das war halt der 49er. Dann den modifizierten hinterher und dann war er auf 51. Mal schauen wenn die nächste Version kommt ob es dann noch funktioniert.

    Frage mich blos keiner nach 64bit ich hab keine Ahnung wo der die downloadlinks auswählt ^^. Oder wie ich da mehr Buttons reinbekomme :-D.

    wegen deinem 51.0.2704.63_chrome_installer[1].175980F911955B04F32D13236E884D87F29489B2&key=cms1 etc.
    Der Updater lädt immer eine chrome_aktuell.exe basierend auf dem channel ( dev, beta, release, ausser Chromium ^^) und entpackt diese. Da kommt halt auch die gleiche chrome.7z, incl. wowhelper etc, bei raus wie bei deinem weg. 😀

  26. Hat denn jemand hier die Chrome portable Version 51.0.2704.63 auch schon einmal auf einem XP oder Vista System gestartet ?.

    Ich habe es unter Vista probiert, Chrome startet auch aber es sind keine Websites aufrufbar. Selbst wenn man die Chrome Einstellungen aufruft, neuer Tab mit leerem Inhalt und das das komische Icon im Tab, wenn Chrome ein Problem mit einer Webseite hat.

    Jetzt kann man die portable Chrome Version wohl auch nur noch ab Win7 starten.

    Oder kann jemand etwas anderes berichten ?.

  27. ChuckBROOZeG says:

    @Marek
    Also die haben bei Chrome die Kompatibilität für XP und Vista entfernt.
    Daher gab es ja auch das Updater Problem. Der Updater hat die XP Binarys gezogen.

    Ich hab heute den meinen neuen Updater nochmal durchlaufen lassen und er hat mir die 51.0.2704.63 auf 51.0.2704.79 aktualisiert. Also für mich jedenfalls funktioniert alles wie gewollt.

  28. @ChuckBROOZeG:

    Klappte bei mir auch, du Held ;-))
    51.0.2704.79

  29. @ChuckBROOZeG
    Ja, daher wurde ja auch der Updater überarbeitet, damit dieser auch die neuen Versionen von Chrome laden kann. Für XP und Vista war glaube ich, bei Version 49 schluss.
    Nutzt Du denn noch Vista oder XP wo ChromePortable 51 startet und Websites anzeigen kann ?. Oder nutzt Du ein moderneres Windows System ?.
    Ich habe unter Vista trotz eingestelltem Support von Google, ChromePortable bis Version 50.0.2661.102 nutzen können. Erst als der Sprung auf Version 51 kam, startet Chrome zwar, aber es lassen sich keine Websites mehr aufrufen.

  30. @ChuckBROOZeG: Die ursprüngliche Version des Updater Skripts hatte Bene unter http://pastebin.com/fa8e9236 bereitgestellt. Da wurde dann noch mehrfach dran verbessert.
    Ich habe eine weiter angepasste Version dieser Ursprungsdatei, keine exe.
    Kann sein, dass die nicht mehr aktuell war und das mit den copy-Befehlen vorher schon umgebaut wurde. Ich bin davon ausgegenagen, dass sich seit 2010 da nix mehr verändert hat.

    @Caschy: Keine Ahnung bei wem jetzt das Copyright/Urheberrecht am Quelltext liegt. Wenn es bei Dir liegt solltest Du ja auch die originale .au3-Datei besitzen. Am Anfang war die, so weit ich mich erinnere, im Updater/ChromePortable-Paket noch mit drinne, ist das jetzt nichtmehr so?

    Ansonsten: Freut mich, dass ich hilfreich sein konnte.

  31. @nurich: Ich stelle dir gerne alles zur Verfügung

  32. @caschy: Das wäre bei ChuckBROOZeG bestimmt gut aufgehoben; er hatte im seinem Kommentar vom 26. Mai nach dem Original-Skript gefragt.

  33. ChuckBROOZeG says:

    Ich schau mir das script von PasteBin demnächst wenn ich Zeit habe mal genau an. Vielleicht steig ich ja durch 😀

    Das sieht auf jedenfall mal komplett anders aus als das was ich mit exe2aut extrahiert habe. viel kürzer 😀
    Ist aber auch logisch.

  34. Der von Caschy oben 26.5.16 verlinkte Updater https://jumpshare.com/v/escG3R7OYhC8k4vq3D4f schafft bei mir über Version Chrome 52.0.2743.82 hinaus unter Win 8.1 und 10 leider kein Update mehr – wenn’s nicht am superlangsamen DSL 0,33 Mbps hier liegt.

  35. ChuckBROOZeG says:

    Also ich habe gerade festgestellt das der neue Chrom (57) den switch für den Profilefolder zu ignorieren scheint. Genauso die Beta (58) so das der Loader bei mir nicht mehr funktioniert.

    Was sie wieder geändert haben keine Ahnung.