Firefox 4.0: inkompatible Erweiterungen installieren

Mittlerweile wurde aus meinem Beitrag zu Portable Firefox 4.0 Beta 1 die Version über 2000 Mal heruntergeladen. Nicht mitgezählt die Schwachstruller (Achtung Smilie: 😉 – für Leute, die das als Beleidigung ansehen), die immer direkt auf die Dateien linken. Nun gab es logischerweise in den Kommentaren die Frage, wie man denn inkompatible Erweiterungen installieren könne. Für viele vielleicht ein alter Hut, für einige etwas völlig Neues.

Einfach mal auf den Screenshot schauen, da könnte es aussehen, wenn man versucht, inkompatible Erweiterungen zu installieren. Was ist also zu tun?

Ganz einfach: erst einmal ein flottes about:config in die Adresszeile geklöppelt und nachfolgende Warnung bestätigen. Danach einen neuen Boolean (per Rechtsklick) mit folgendem Text anlegen: extensions.checkCompatibility.4.0b. Die danach abgefragte Value sollte False sein.

Danach klappt es auch mit inkompatiblen Erweiterungen. Bedenkt aber: nicht jede Erweiterung ist danach auch wirklich 100% fehlerfrei nutzbar.

An dieser Stelle ein Danke an Gonzo, der bereits in den Kommentaren einigen Lesern hier half. Weiteres Firefox-4.0-Anpass-Gedöns findet ihr auch im verlinkten Beitrag.

Gefällt dir der Artikel? Dann teile ihn mit deinen Freunden.

Hallo, ich bin Carsten! Ich bin gelernter IT-Systemelektroniker und habe das Blog 2005 gegründet. Seit 2008 ist es Beruf(ung). Baujahr 1977, Dortmunder im Norden, BVB-Fan und Vater eines Sohnes. Auch zu finden bei Twitter, Facebook, Instagram und YouTube. PayPal-Kaffeespende. Mail: carsten@caschys.blog

Neueste Beiträge

Mit dem Absenden eines Kommentars stimmst du unserer Datenschutzerklärung und der Speicherung von dir angegebener, personenbezogener Daten zu.

37 Kommentare

  1. Ich hatte es gestern schon ohne „.4.0b“ versucht. Da ging es nicht. Jetzt weiß ich woran es lag 😉

  2. @Novo

    Kann nur noch eine Frage der Zeit bis Xmarks auch unter 4.0 funktioniert. In der zwischen zeit verwende ich Firefox Sync als Ersatz.

  3. Danke Carsten, wie immer, für die Info!

    Und hey Martin aka. Schrotty (*dem Namen machst Du Ehre):
    Du tauchst fast überall im Netz Negativ auf, egal wo ich bis Dato ein Kommentar von Dir gelesen habe! Solltest Du mal darüber nachdenken, scheinst ja wohl auch schon was älter zu sein!

    … greetz from me!

  4. Ja nen is klar… Beta-Versionen nutzen wollen, aber dann nicht wissen wie man inkompatible Addons zum laufen bekommt. Jungs, dann lasst doch mal lieber die Finger von Betas, wenn ihr damit nicht umgehen könnt. Nich das dann auch noch das Geheul losgeht, weil irgendwas kaputt ist.

  5. @Tyr0n

    Das halte ich für ein Gerücht. Bitte mal um beweise wenn möglich denn ich kann mich nicht in dem letzten Monaten daran erinnern und wenn, waren es Kleinigkeiten die keinen mehr heute interessieren.

  6. „@caschy nein aber wollte es nur erwähnt auch haben“

    „und wenn, waren es Kleinigkeiten die keinen mehr heute interessieren.“

    @Martin
    Vergessen du musst, was früher du gelernt!

  7. BlaBlub BlibBlum BlabBalim Balilub Kubi Tub Kum Blib Blem.

  8. JürgenHugo says:

    Ei wei, was bin ich froh, das ich nur kommentiere. Manches, was da über Links steht, das kommt mir so vor, als ob kleine Kinder im Sandkasten sich um die Schüppe streiten…

    Einer macht sich Mühe, und ein anderer greift oder schreibt das ab – das hats immer schon gegeben. So sind nicht wenige schon zu Dr./Prof.-Titeln und Wissenschaftsruhm gekommen…DIE nennen natürlich den eigentliche Schöpfer erst recht nicht – aber das liegt ja in der Natur der Sache.

    Wenn mich wegen dieser Bemerkungen jemand „angehen“ möchte – dann kann er das ruhig – ich kann schon was ab. Aber ich kann auch abgestuft antworten… :mrgreen:

  9. Danke für die Ganzen FF-Win tips sieht jetzt richtig geil aus!

  10. @Martin:
    XMarks unter FF4 dauert noch ewig,
    die Entwickler sagten, dass sie sich nicht um FF Betas kümmern.

    Hier noch mein portable Firefox special, (based on PortableApps Laucher) NUR 19MB!
    http://www.share.cx/files/846938002872/Firefox4.0b2pre_portable_byNovo.rar.html

  11. Vielen Dank für die guten Tip !!

  12. Diese Methode kann ich nicht empfehlen, da hatte ich nicht die besten Erfahrungen mit. Das habe ich vor einer Ewigkeit mal ausprobiert, danach wollte Firefox nicht mehr starten, da er zerhackt wurde. Das war damals eine ganz wilde Geschichte. Und immer schön Backups machen, wie ich.
    Mein Tipp: lieber Finger weg! Es gibt dafür ja bekanntlich das Add-on MR Tech Toolkit, das ich uneingeschränkt empfehlen kann. Es läuft wie geschmiert.

  13. JürgenHugo says:

    @Adam:

    Das ist bei mir anders. Ich mach/hab sowohl mit NTT, Mr. Tech als auch über about:config. Klar ist mir der Fox auch mal abgeschmiert – das hielt sich aber sehr im Rahmen.

    Und da ich immer ein zeitnahes Backup vom Profilordner habe (läuft automatisiert) und auf dem Mac einen 2. Fox – da hält sich das Risiko sehr in Grenzen.

    Als Beispiel: ich hab auch schon total inkompatible Themes „reingedrückt“ – das sah dann zwar manchmal gräuslich aus, aber passiert ist nich viel. :mrgreen: Der Fox ist schon recht robust und hält auch meine Attacken meist irgendwie aus, grins.

Es werden alle Kommentare moderiert. Lies auch bitte unsere Kommentarregeln:

Für eine offene Diskussion behalten wir uns vor, jeden Kommentar zu löschen, der nicht direkt auf das Thema abzielt oder nur den Zweck hat, Leser oder Autoren herabzuwürdigen. Wir möchten, dass respektvoll miteinander kommuniziert wird, so als ob die Diskussion mit real anwesenden Personen geführt wird. Dies machen wir für den Großteil unserer Leser, der sachlich und konstruktiv über ein Thema sprechen möchte - gerne auch mit Humor.

Du willst nichts verpassen?

Neben der E-Mail-Benachrichtigung habt ihr auch die Möglichkeit, den Feed dieses Beitrags zu abonnieren. Wer natürlich alles lesen möchte, der sollte den Hauptfeed abonnieren.