YouTube langsam? So misst man die Geschwindigkeit und dieser Trick soll Abhilfe schaffen

30. April 2013 Kategorie: Internet, geschrieben von: caschy

Einige Leser haben uns mittlerweile E-Mails geschickt, deren Inhalt beschreibt, wie man das Laden von YouTube-Filmen beschleunigen können soll. Als Nicht-Betroffener kann ich nur die betroffenen und etwas erfahreneren Benutzer bitten, diesen Trick bei Gelegenheit auszuprobieren und hier in den Kommentaren etwas Feedback zu hinterlassen. Technischer Hintergrund? YouTube liefert Inhalte an Daten verteilende CDN-Server (CDN = Content Distribution Network); blockt man diese mittels Firewall-Regel lokal oder im Router, dann kommt im besten Falle das Video direkt von der Quelle.

YouTube

Dieser Trick funktioniert natürlich nur, wenn euer Provider nicht schon YouTube direkt in Drosselhaft hat. Ich gehe hier einmal auf die erfahrenen Benutzer ein, die das Ganze in wenigen Minuten erledigen können. Am besten probiert man das Ganze erst einmal lokal aus. Windows-Benutzer können sich eine Filterregel zusammenklicken, die die CDN-Server blockt, alternativ geht das Hinzufügen und Entfernen von Regeln natürlich per CMD.

So fügt man eine Blockregel der Windows-Firewall hinzu. CMD als Admin aufrufen (funktioniert unter Windows 8 so) und folgenden Befehl eingeben:

netsh advfirewall firewall add rule name="YoutubeCDN" dir=in action=block remoteip=173.194.55.0/24,206.111.0.0/16 enable=yes

(das Entfernen der Regel geht auch über CMD oder die Oberfläche der Windows-Firewall):

netsh advfirewall firewall delete rule name="YoutubeCDN"

Firewall

Wie ich bereits oben erwähnte: ich bin nicht betroffen, die Speed-Anzeige von YouTube an meinem Ort (Langen, Niedersachsen & Kabel Deutschland @ 32MBit) zeigt derzeit das folgende Bild an:

MySpeedBei unserem Sascha, der in Aue sitzt, sieht es etwas anders aus (Telekom, VDSL @25 Mbit) – aber der sagt aus, dass er eigentlich keine YouTube-Probleme hat.

youtubedietraurigewahrheit

Ihr selber könnt euren YouTube-Speed hier testen. Sollte dieser Trick klappen, dann wird er dies auch nur, wenn nicht die halbe Welt so agiert – denn dann sie die Server auch schnell direkt überlastet.

Hier noch einmal kurz für die Mac-Heads, unter Linux müsste es meines Wissens mit dem Befehl iptables statt ipfw funktionieren. Einfach im Terminal eingeben.

sudo ipfw add reject src-ip 173.194.55.0/24 in
sudo ipfw add reject src-ip 206.111.0.0/16 in

Regeln auf dem Mac lassen sich mit sudo ipfw list anzeigen und mit sudo ipfw delete Regelnummer löschen.

So Freunde der gepflegten Langsamkeit: testet den ganzen Spaß mal, wenn es besonders schlimm ist und lasst hören, ob das funktioniert oder eher im Bereich Homöopathie und Schlangenöl einzuordnen ist. (via, via & via + Danke an alle Einsender!)


Vielen Dank für das Lesen dieses Blogs! Wenn ihr uns unterstützen wollt, dann schaut euch auch diese Advertorials an, die wir auf separaten Seiten geschaltet haben: HP Cashback Aktion. Danke, jeder Aufruf hilft uns.

Neueste Beiträge im Blog

Gefällt dir der Artikel?
Dann teile ihn mit deinen Freunden.
Nutze dafür einfach unsere Links:
Über den Autor: caschy

Hallo, ich bin Carsten! Dortmunder im Norden, Freund gepflegter Technik, BVB-Maniac und Gründer dieses Blogs. Auch zu finden bei Twitter, Google+, Facebook, XING, Linkedin und YouTube.

Carsten hat bereits 16989 Artikel geschrieben.


129 Kommentare

evilbaschdi 30. April 2013 um 15:28 Uhr

handelt es sich hier tatsächlich um eine statische ip oder darf ich die firewallregel alle 24 stunden händisch anpassen?? Feedback gibts später.

Alessandro 30. April 2013 um 15:30 Uhr

Ausprobiert und siehe da – YouTube wirkt deutlich flotter – 1080p startet in 2 Sekunden

josse 30. April 2013 um 15:32 Uhr

Nix mit Schlangenöl: bei mir dauerte es meistens ein paar Sekunden, vor das Video überhaupt zu laden anfing. Jetzt kommt es mir vor, als hätte ich eine richtig schnelle Internetverbindung. Was ich im Moment leider nicht habe. Vielen Dank!

evilbaschdi 30. April 2013 um 15:34 Uhr

ok, und wie klatsch ich das jetzt in die fritzbox blacklist?

Bobo 30. April 2013 um 15:39 Uhr

Ich hab das Problem dass YouTube auf meinen Android Geräte total laggt, auf dem PC gibt’s aber keine Probleme. Jemand eine Idee an was das liegen könnte?

Dirk K. 30. April 2013 um 15:39 Uhr

Mal ausprobieren, hier gibt es das für Android (SGN 10.1):
http://forum.xda-developers.co.....?t=2222747

Marcel Marnitz 30. April 2013 um 15:40 Uhr

Verrückt^^ Jetzt lade ich sogar Videos mit 12000 kbit/s (was ungefähr meine Leitung entspricht). Problematisch ist es bei mir nur abends (gestern war es mal wieder extrem). Heute Abend wird also weitergetestet! :)

Ranger 30. April 2013 um 15:43 Uhr

Wie kann ich diese Speed-Angabe von YouTube interpretieren?
http://www.pic-upload.de/view-.....t.png.html

Ich hatte vor ein paar Tagen das Gefühl, dass mein ISP (Unitymedia) auch Youtube bremst – heute ist aber alles in Butter und selbst 4k startet sofort.
Haben andere bei Unitymedia ein ähnliches Diagramm oder gab es ein Problem mit meinem Anschluß?

Georg 30. April 2013 um 15:46 Uhr

Ich weiß nicht ob es geht, aber man kann vielleicht auch einfach die IPs oder Webseiten der CDN-Anbieter in der hosts-Datei sperren. Dann klappt der Trick auch auf Android, wenn man keine Firewall einsetzt. ;) Und unter Mac, Linux etc. sowieso.

Danke für den Tipp Caschy!

Benny 30. April 2013 um 15:48 Uhr

Gebookmarkt! Muss ich bei späterer Gelegenheit direkt mal ausprobieren. Ich werd hier dann noch ein kleines Feedback schreiben ;)

LG!

Stoney 30. April 2013 um 15:50 Uhr

Wow Danke…
DSL 2000 – 4 User

Gefühlt hat sich am Aufbau der Seite nichts getan, aber das Video selbst scheint schneller zu starten und zu laufen, ich denke aber ich bin hier einem kleinen Selbstbetrug auferlegen.
Ich werde den Eintrag mal setzen, wenn mir Youtube mal wieder besonders langsam vor kommt.

Erklärt das ganze auch warum ich nach reconnects manchmal deutlich bessere Verbindungen bekomme? Also Quasi ne neue bessere Route zum cdn Server?

–> Alles nur gefühlte Werte, den Test von Youtube kann ich nur sehr schlecht auswerten, da ich regelmäßig drei versch. verb. benutze. Ist bei mir also sowieso ne wilde Wellenlinie die Kurve

Freue mich schon auf weitere Berichte zu dem Thema

Benjamin S. (@xstanzx) 30. April 2013 um 15:51 Uhr

Wir konnten keine Videowiedergaben von deinem Standort finden.

Stoney 30. April 2013 um 15:52 Uhr

@Ranger

Ich hab solche Spitzen, wenn ich eine andere Internetverbindung nutze, deren Bandbreite deutlich über meiner eigenen ist ^^
Mal in der Uni oder an nem Hotspot kurz angemeldet und ein Video geschaut? Ich kann diese Grafik unter meinem Account dank 4 unterschiedlichen Bandbreiten so gut wie garnicht auswerten :(

Ranger 30. April 2013 um 15:59 Uhr

@Stoney
nee, war immer der eigene Anschluss.

Bulli 30. April 2013 um 16:00 Uhr

Mit Windows XP SP3 geht es über die Kommandozeile nicht. In der grafischen Oberfläche der Firewall finde ich auch nichts passendes.

Schade.
Bei mir laggt nämlich Youtube wie die Seuche.

PS: Ich bin bei der Drosselkom (DSL3000).

Crom 30. April 2013 um 16:01 Uhr

ich bin bei unitymedia und habe eigtl keine probleme mit youtube. video startet schnell. auch 1080p ist rasant. allerdings beobachte ich etwas merkwürdiges seit einiger zeit. längere videos buffern (kleiner grauer balken) und dann stopt das buffern einfach. sagen wir ein video ist 10minuten lang dann stopt das bufern bei 2minuten ca. wenn die wiedergabe dort angekommen ist ist es vorbei mit gucken. ich muss dann die seite neustarten wobei dann aber alles in einem durchläuft. manche videos bufern garnicht, laufen aber komplet durch auch in 1080p. andere laufen überhaupt nicht.speziell bei der ersten beobachtung wirkt es so als sei eine hürde eingebaut. nach dem motto “das ist aber ein ziemlich großes video dass er da gucken will. da stoppen wir ihn erstmal. wenn er es wirklich sehen will kann er ja neustarten”. kennt einer das phänomen?

aniSation 30. April 2013 um 16:02 Uhr

Das werde ich auch mal probieren. Bisher nutze ich einen Proxy in den Staaten um Youtube erträglich schnell zu bekommen. Das funktioniert auch sehr gut.

Ranger 30. April 2013 um 16:06 Uhr

@Crom: genau das hatte ich auch die letzten Tage beobachtet, heute läuft aber sogar 4k ohne Probleme durch.

sniperde 30. April 2013 um 16:09 Uhr

Werde das auch am Wochenende am Telekom Anschluss mit 16 mbit testen.
Da geht nämlich egal zu welcher Tageszeit nicht einmal 720p oder 480p OHNE Aussetzer zum nachladen. Alle nicht Telekomnutzer haben das Problem in unserer Nachbarschaft nicht, trotz DSL.

Danke für den Tip!

danielschmid1993 30. April 2013 um 16:16 Uhr

also ich als 1&1 user, wie hier auch schon öfters erwähnt
sehe das problem der “drossel” auch bei mir
am nachmittag geht es nach einigermaßen bei 720p
und am abend ist oft auch schon mit 480p der gar aus
es buffert nicht und bleibt einfach nach ein paar sekunden stehen
am tablet gehts aber irgendwie
16k leitung
vor einem monat hatte ich die probleme nicht!
da konnte ich 20x 1080p tabs offen haben und alle haben in ruhe gebuffert bis zum ende :)
und ich konnte auch sogar teilweise flüssig ohne buffern 4k anschauen
und jetzt sagt mit jdownloader das es 20std zum laden brauchen würde….. ahja… nein danke!!! gleich heute abend testen :) danke

Mama007 30. April 2013 um 16:18 Uhr

werde ich gleich zu Hause testen, gehöre auch zu den Opfern. Was wäre der Weg für die Fritz-Box? einfach die IP in die Blacklist?

danielschmid1993 30. April 2013 um 16:23 Uhr

@mama007
ja genau
ist ja im endeffeckt s gleiche wie diese am pc zu blocken
nur halt dann für alle :)

archhead 30. April 2013 um 16:24 Uhr

Scheint hier zu funktionieren nach einem ersten Test. Schöne Sache, Danke.

Semih 30. April 2013 um 16:26 Uhr

Schon arm das man selbst Hand anlegen muss und der riese “Youtube” sich nicht drum kümmert!

Konstantin 30. April 2013 um 16:41 Uhr

gleiches Phänomen wie bei @danielschmidt… – Auf dem Desktop extrem langsam (teilweise wird eine Minute 340p Video erst in 5 Minuten komplett fertig gebuffert) – Später mehr…

lempire 30. April 2013 um 16:53 Uhr

bin ich richtig in der annahme, dass sobald sich die ip des cdn-servers ändert dieser trick nicht mehr funktioniert?
wenn ja,
könnte da nicht jemand eine kleines prog coden das mir immer die aktuellste ip mir in meine firewall schreibt?
damit dieser trick dauerhaft funzt

David 30. April 2013 um 16:57 Uhr

Also ich hab seit neustem das Problem, dass sich Videos ab 480p nicht mehr vorspulen lassen. Beim Versuch startet das Video ständig neu. Dieses Problem hatte ich noch vor 2 Wochen nicht. Leider kann dieser Trick das Problem nicht beheben ;(

lempire 30. April 2013 um 17:13 Uhr

nach ein paar testvideos kann ich folgendes sagen(Telekom DSL16000) :

Man hat sich ja schon mit der Zeit angwöhnt videos erst puffern(der graue balken) zu lassen damit das video ruckelfrei durchläuft.
Dies ging aber die letzten Jahre bei der Telekom nicht mehr. Da hat er nur noch je nach Videolänge gefühlt 1Minute gebuffert und nicht das ganze Video.

Dies geht mittels des Trick nun wieder einwandfrei. und das alleine ist es schon wert.
Zur Geschwindigkeit kann noch nichts sagen, das muss ich erst noch in den Abendstunden testen.

Thomas Baumann 30. April 2013 um 17:19 Uhr

Kanns nich testen, bei mir ist grad alles lahm. Max 8KB/s. Bin über 5GB gekommen ^^”
Aber Kumpel (der hat das Problem auch) ist informiert :)

Manu 30. April 2013 um 17:25 Uhr

es scheint bei mir auch schnell zu laden…

Torti_78 30. April 2013 um 17:31 Uhr

Bei mir (Ingolstadt, Kabel Deutschland @100Mbit/s) scheint wie bei caschy alles OK.

Josef Türk 30. April 2013 um 17:39 Uhr

Ich habe die IP in die Blacklist der Fritz Box eingetragen und ich muss sagen Wruuuuum, das geht ab wie Schmitzens Katze. Habe vorher mal die Seite von YouTube angesehen und da war ich bei 4Mbit/s trotz VDSL 50.
Der Hinweis ist genial, da hast du was angestoßen. Danke dafür.

Sebastian (@dersharky) 30. April 2013 um 17:50 Uhr

Schade bei mir funktioniert die Anzeige nicht. Kann es also nicht überprüfen. Ich glaube allerdings schon das die Videos besser laufen.

Sebastian (@dersharky) 30. April 2013 um 18:13 Uhr

Ich habe das Gefühl, das diese YTSpeedtest mit einem v6 Tunnel nicht funktioniert.

Oliver B (@funnyoliver221) 30. April 2013 um 18:32 Uhr

Jawoll :) Funtzt wunderbar … vorher bei nem 720p Video 5 Minuten warten und nur 5 Sekunden gucken können … jetzt innerhalb von 5 Sekunden mindestens eine Minute geladen :)

Tom 30. April 2013 um 18:33 Uhr

Ich bin bei 16 und hab eine 30er Leitung. Wieviel % von der eigentlich versprochenen Geschwindigkeit ist normal?

Stefan Döhring 30. April 2013 um 18:42 Uhr

@Josef Türk: Einfach 173.194.55.0/24 in die Blacklist, oder muss man den Eintrag noch speziell formatieren? Scheint nämlich nicht so ganz zu klappen bei mir (Unitymedia).

evilbaschdi 30. April 2013 um 18:42 Uhr

@Josef Türk: Wie trage ich die IP Range korrekt in die Blacklist der FritzBox ein?

Matze.B 30. April 2013 um 18:42 Uhr

Was bedeutet ‘Wir konnten keine Videowiedergaben von deinem Standort finden.’?
Der schwarze Balken, der wohl die eigentliche Aussage bringt, fehlt bei mir!

Josef Türk 30. April 2013 um 18:48 Uhr

Ich habe die IP einfach in die Blacklist so eingetragen ohne irgendwas dazu und das läuft einwandfrei
173.194.55.0
206.111.0.0
Zu finden unter Internet, Filter, Listen, dort dann Blacklist.

evilbaschdi 30. April 2013 um 18:52 Uhr

aber spert das nicht nur die ip an sich und nicht die komplette range?

evilbaschdi 30. April 2013 um 18:57 Uhr

scheint absolut wirkungslos, josef. selbst, wenn ich ne ip direkt sperre und manuel über den browser ansurfe, kann ich noch darauf zugreifen.

Oweh 30. April 2013 um 18:57 Uhr

Hmpf, keine Änderung. Ab Schule aus ist YouTube nicht mehr zu gebrauchen. Das wird von Woche zu Woche schlimmer. Na, guck ich halt Abends kein YouTube mehr. Nicht so schlimm.

Josef Türk 30. April 2013 um 18:59 Uhr

Bei mir klappt das konnte bislang nie 1080p sehen jetzt geht das einwandfrei.

Andreas 30. April 2013 um 19:10 Uhr

Mit und ohne Eintrag in die Blacklist der FB 7330 sieht es so aus:

https://www.dropbox.com/s/mtu45h1eljmksin/Zwischenablage01.jpg

Ist da noch Hilfe?

Grüße
Andreas

Speedy 30. April 2013 um 19:12 Uhr

Wahooo, toll klappt 1A! Danke für den Tip.

Josef Türk 30. April 2013 um 19:15 Uhr

@ Andreas und andere
Das sah und sieht bei mir auch so aus. Vorher war an 1080p Stream nicht zu denken, jetzt ruckelfrei und der Ladebalken eines 9 Minuten Videos war in 2:40 Minuten voll.
Vielleicht solltet ihr die Boxen neu starten. Meine Box ist eine FB 3370

dericy 30. April 2013 um 19:19 Uhr

Ick könnt’ dir knutschen! Jetzt geht Youtube auch wieder im Fullscreen in HD Auflösung! Und OHNE ewige Pufferpausen!!! Danke für diesen tollen Tipp!!!

Marcel Marnitz 30. April 2013 um 19:33 Uhr

Telekom 16k DSL (C&S C+) und YouTube rennt wie sau (gestern Abend lief es überhaupt nicht um diese Uhrzeit)

Fettes Danke! :)

Mirko Lange 30. April 2013 um 19:54 Uhr

super tipp! Youtube ist jetzt deutlich schneller. Sogar in höchster HD Auflösung. So macht das Spass! PS: Mein DSL Anbieter ist Kabel-Deutschland.

Anton 30. April 2013 um 20:00 Uhr

Auch wenn man es nicht glauben mag, dass selbst VDSL50 für YT “zulangsam” ist.
Bei mir hat es merklich funktioniert :) Danke!
Geht natürlich auch mit allen Firewalls wie Comodo wo man Adresssbereiche sperren kann.

Alf 30. April 2013 um 20:06 Uhr

heute Mittag hat hat es bei mir bestens funktioniert! jetzt ist schon wieder alles vorbei :-/

Freakyno1 30. April 2013 um 20:14 Uhr

@Josef Türk:
Kann das leider nicht ganz nachvollziehen, denn um die Blacklist zu aktivieren muss erst die Kindersicherung für den PC scharf geschaltet werden. Ohne die ist die Blacklist praktisch ohne Wirkung. ;-)

Maci 30. April 2013 um 20:24 Uhr

Der Geschwindigkeitstest funktioniert auf keinem meiner Mac’s. Zitat: “Wir konnten keine Videowiedergaben von deinem Standort finden.” Getestet hab ich es mit Safari Chrome und Firefox. Woran könnte es liegen?

Dustman 30. April 2013 um 20:30 Uhr

Kaum zu glauben, es funktioniert. Wohne in Essen, VDSL25er Telekom Leitung, und mit dem “Trick” macht Youtube auch wieder Spaß!

Brater 30. April 2013 um 20:43 Uhr

Bei KabelBW ( == UnityMedia) gibt es seit einigen Tagen auch massiv Probleme. Die Youtube-Benchmark-Seite erzählt mir was von 24 mBit. Bei aktuellen Videos läuft auch alles durch aber ältere Videos bleiben hängen oder die Gesamtzeit wird irgendwann verkürzt. Habe gerade ein Video im Fenstermodus lauf und auf 720p gestellt: ca. alle 5 Minuten 2 Sekunden Video. Diese Säcke.

Stefan Döhring 30. April 2013 um 20:48 Uhr

Auf dem iPad mit der Youtube-App von Google ist es auch ganz schlimm im Moment (zumindest bei mir). Auch mit dem Blacklist-Trick auf der Fritzbox.
Da man ja leider keine Auflösung forcieren kann wechselt der Stream immer schön zwischen 240p, 360p, 480p und 720p (?) hin und her, sogar während der Wiedergabe und abhängig von der Uhrzeit. Teilweise wird sogar die Audio-Spur mal nach Lust und Laune in der Qualität runtergestuft. Ein sehr unbefriedigendes Guck-Erlebnis.
Kennt jemand eine gute App für Youtube, mit der man diese Probleme nicht hat, oder umgehen kann (feste Videoqualität, etc.)? Darf auch gerne was kosten!

Unbekannt 30. April 2013 um 20:52 Uhr

Habe XP. Frage: wird es klappen, wenn ich in dem “hosts”-File einfach
127.0.0.1 c.youtube.com
eintrage?

Eggerd 30. April 2013 um 20:54 Uhr

Woran kann es liegen, das bei meinem “Speed-Test” kein schwarzer Balken zu sehen ist?
Über den Diagrammen steht bei nur “Wir konnten keine Videowiedergaben von deinem Standort finden.”

Muss man da noch irgend etwas besonderes machen? Gruß, Eggerd

Wolfgang Wagner 30. April 2013 um 20:58 Uhr

Scheint bei mir auf einem Mac nicht zu funktionieren. Oder muss man danach einen Neustart oder so durchführen?

Brater 30. April 2013 um 21:01 Uhr

Super… es scheint zu funktionieren. Mit dem Ergebnis, dass das Webradio parallel mit den Youtube-Streams abkackt. Die Leitung hat 3mBit… Das ödet doch an.

Josef Türk 30. April 2013 um 21:15 Uhr

Zitat Fritzbox Text:
Auf dieser Seite können Sie Listen erstellen und bearbeiten, die für die Nutzung von Internetfiltern und Priorisierungsregeln benötigt werden.
Filterlisten
Hier können Sie eine Liste gesperrter Internetseiten (Blacklist) und eine Liste erlaubter Internetseiten (Whitelist) erstellen und bearbeiten. Den einzelnen Computern kann in den Zugangsregeln eine dieser Listen zugeordnet werden.
Wenn ein Filter für Internetseiten aktiv ist, ist der direkte Aufruf von IP-Adressen generell gesperrt. Ausnahmen können Sie in der Liste erlaubter IP-Adressen festlegen.

Hinweis:
Über die Kindersicherung können nur Netzwerkanwendungen gesperrt werden, die ausschließlich die Protokolle TCP und UDP nutzen.

Ich denke nun sollte klar sein wie es geht oder ;-)
.

Brater 30. April 2013 um 21:34 Uhr

Bei KabelBW scheint dieser Trick ebenfalls nicht zu funktionieren :-/

Jakob 30. April 2013 um 21:40 Uhr

@lempire
Wie Caschy schon sagte, die IP eines CDNs ändert sich nicht. Niemals.

Ausnahmen bestätigen die Regel.

Alf 30. April 2013 um 21:45 Uhr

@Stefan Döhring wenn dein iPad ein Jailbreak hat kann ich dir ProTube empfehlen

Simon 30. April 2013 um 22:01 Uhr

ich kann es bestätigen. Habe hier zu Hause DSL 16000 und erhalte beim normalen surfen rund 14 MBit. Der Youtube Speedtest zeigt für meinen ISP 4.8 MBit/s an. Jetzt geht es rund mit Videos laden! 1080p kein Problem mehr und stark verkürzte Wartezeiten! Danke! Ich wer das am Donnerstag im Büro testen, da habe ich 1Gbit/s :-)

Timo 30. April 2013 um 22:18 Uhr

Mal eine ganz blöde Frage. Wenn ich das manuell machen möchte (in der Windows Firewall oder Comodo oder….), was bedeutet die Zahl hinter dem / ? Hier 173.194.55.0/24 die “24” und wie trage ich diese in die Firwall GUI ein?

Marco 30. April 2013 um 22:33 Uhr

@Caschy: Hab es mal getestet und bei mir bringt es nichts, ist aber auch nicht verwunderlich. Wenn man das ganze mal betrachtet blockt der Tipp 2 der subnetze der Google CDN`s das ist ein Tropfen auf den Heißen Stein und vielleicht bei der Tipp Quelle zufällig eines der betroffenen CDNs. Betrachte ich meine Firewall Logs nach den Sperren erhalte ich nicht mal Zugriffe aus dieser IP Range sondern über ein komplett anderes CDN.

Da Google / Youtube CDN`s seit Jahren mit Anycast arbeiten ist das auch kein Wunder, mag bei einem User in Berlin diese IP Range genutzt werden so kann ein User in München möglicherweise auf komplett andere Ressourcen zugreifen. Jedenfalls lange Rede kurzer Sinn, in meinen Logs waren nun nach etlichen Minuten Youtube nicht ein Hit auf die beiden Sperr Regeln zu finden.

Marco 30. April 2013 um 22:39 Uhr

Noch kurzer Nachtrag an die unwissenden Fragen:

Wer andere Firewalls nutzen möchte und es dennoch probieren mag die /16 /24 hinter den IP`s bedeuten die Range. Also im Fall /24 1-255 > ###.###.###.* und im Fall /16 sogar ###.###.*.*

@Caschy: Immer mehr seltsames Achselzucken bei mir, beide Netze gehören nicht mal Google / Youtube. Nur das erste da andere ist XO Net welche nur Anycast Peers in US betreiben. ?!?! Ein Block ist also irgendwie… Sinnfrei?!?

David Maciejewski (@macx) 30. April 2013 um 22:47 Uhr

Ich hatte mit 50 MBit der Telekom immer Probleme. YouTube-Videos waren stets ätzend langsam. Nun rennt es. Danke!

Jomei 30. April 2013 um 22:53 Uhr

Dieser Youtube Speed zeigt aber auch nicht so ganz die Realitaet. Seit letzten Donnerstag habe ich massiv Probleme. Speed ist nur 80 – 200 kbit, damit ist Video schauen unmoeglich. Aber, <– es betrifft nur Videos, die aus EU / Deutschland wohl zu YT geladen wurden. Nehme ich Videos, die aus anderen Regionen kommen, wie USA, Südamerika, Asien etc, dann habe ich full speed. Da duerfte wohl eher was bei YT nicht ok sein.

Ich werde mal die FW Settings pruefen.

Timo 30. April 2013 um 22:56 Uhr

Danke für die Tips. Habe es mittlerweile hinbekommen aber ich merke mit 1&1 keinen Unterschied, egal ob Firewall-Regel + Proxy oder Firewall-Regel ohne Proxy. Schade.

Auf dem N4 ist YouTube mittlerweile gar nicht mehr zu gebrauchen.

Jomei 30. April 2013 um 23:04 Uhr

So, getestet. Mit der FW Rule full speed, ohne schnecke ich bei rund 150 kbit rum, aktuell. Danke fuer die Info. Man YT, bei euch ist das was verstopft, in der Leitung. Oder wo auch immer.

Tomek 30. April 2013 um 23:06 Uhr

Versucht es doch einfach mal mit: SmartVideo For YouTube. Das Addon gibts für Opera, FireFox und Chrome. Seitdem ich das Addon nutze hatte ich noch nie Probleme. Der puffert alle Videos mit Full Speed!!!

https://chrome.google.com/webstore/detail/smartvideo-for-youtube/lnkdbjbjpnpjeciipoaflmpcddinpjjp

sprech.sucht (@Sprechsucht) 30. April 2013 um 23:09 Uhr

Das sind die Linuxkommandos:
sudo iptables -A INPUT -s 173.194.55.0/24 -j REJECT
sudo iptables -A INPUT -s 206.111.0.0/16 -j REJECT

Um die Filter dauerhaft zu setzen, sollte man die Regeln an geeigneter Stelle eintragen oder es grafisch mit Firestarter probieren: http://www.fs-security.com (die Distros sollten entsprechende Pakete haben)

Und Root-Androiden kann man mit custom rules für DroidWall bearbeiten:
# stop YouTube from sucking
$IPTABLES -A "droidwall" -s 173.194.55.0/24 -j REJECT
$IPTABLES -A "droidwall" -s 206.111.0.0/16 -j REJECT

Freakyno1 1. Mai 2013 um 00:24 Uhr

“Den einzelnen Computern kann in den Zugangsregeln eine dieser Listen zugeordnet werden.”

Und wo befinden sich diese Zugangsregeln? ;-)

frank katzer 1. Mai 2013 um 00:36 Uhr

wow. gleich mal den router konfiguriert. hammer. hatte noch nie so einen schnellen preload von hd-videos. danke für den tipp!

Mama007 1. Mai 2013 um 01:42 Uhr

173.194.55.0/24 … genau das habe ich soeben in die Blacklist der FB eingetragen. Und es “fluppte” plötzlich was vorher nicht mehr ging. Ich gebe die Erfolgsmeldung aber nur unter Vorbehalt. Es ist mitten in der Nacht, Nachbarn und meine Teenies sind im Bett. Hardcoretest kommt morgen. Aber so problemfrei hatten wir es schon seit Wochen zu keiner Tages- oder Nachtzeit.

Mark Bott 1. Mai 2013 um 01:53 Uhr

Hammer. Kann hier mit DSL-RAM (sync max. 3,6 Mbit) nun 1080p Fullscreen.
Sagt mal, ist das nicht Einmischung in den Datenverkehr seitens der Telekom?
Soweit ich das in Erinnerung habe, darf ein ISP doch nicht anderes als IP Pakete unverändert weiterleiten…. – das scheint dann hier ja wohl nicht gegeben :(

Andi 1. Mai 2013 um 09:46 Uhr

@evilbaschdi: Ich war mal so frei und habe das hier beschrieben, weil ich selber erst suchen musste: http://goo.gl/BBJGY
Ich war von der geringen Geschwindigkeit betroffen und fand den Tipp hier von Caschy super.
Angebunden bin ich mit VDSL50 bei der T-Kom … ich weiss, “begrenzte” Flat, aber abwarten und kucken, was sich entwickelt.

Dirk 1. Mai 2013 um 10:56 Uhr

Unter Ubuntu lautet der Befehl:
Sudo iptables -A INPUT -s 173.194.55.0/24 -j DROP
Sudo iptables -A INPUT -s 206.111.0.0/16 -j DROP

dakdroid 1. Mai 2013 um 11:18 Uhr

Ich habe auf die schnelle eine Android app geschrieben, welche die ranges blockt:
xda thread:
http://forum.xda-developers.co.....?t=2259167

download:
http://goo.gl/VVKXp

DanielF 1. Mai 2013 um 11:32 Uhr

Sehr gut jetzt lädt yt so schnell wie noch nie zuvor videos und das bei nur DSL 2000 :)

Henkeyy 1. Mai 2013 um 13:18 Uhr

Kann mir jemand sagen wie ich das in dem Router Speedport W 701v der Telekom einstelle?
Ich finde nichts wie eine Blacklist :(

Jomei 1. Mai 2013 um 15:01 Uhr

So, ich habe die FW Regel wieder geloescht. Nach einigen Stunden Test brachte es mehrere Nachteile:

Begruendung. Ich habe eine 2 MBit Leitung. Ohne die Regel werden die Video nur mot (im Schnitt 150 kbit) geladen. Video schauen macht keinen Spaß.

Mit Regel mit rund 2 MBit, aber wenn ich das Video stoppe, dann hält der Download kurz danach an. Ich muss es abspielen, damit weiter geladen wird. Mit 2 MBit ist 720p nicht möglich. Das Video stoppt trotzdem alle paar Sekunden.

Ohne die Regel läd es zwar langsam, aber ich kann das Video stoppen und YT läd das Video bis zum Schluss, dann auf Play und gut ist.

Und ganz wichtig. In der IP Range scheinen mehrere Updateserver von Online-Spielen zu liegen. Die sind nicht mehr erreichbar. Ohne Regel ja, mit Regel nicht. Gerdae lade ich, ohne Regel, mit 1.7 MBit. Das ist ganz ok und die Nachteile (bei mir) finde ich nicht so gut. Also, FW Regel wieder gelöscht.

Franky 1. Mai 2013 um 15:04 Uhr

Also unter Windows XP geht das leider nicht. Im CMD gibts ne Fehlermeldung, dass netsh den Befehl nicht kennt.

Hat jemand ne Lösung für Windows XP?

karmalocity 1. Mai 2013 um 16:10 Uhr

Kann auch bestätigen, dass der “Trick” funktioniert. Habe hier DSL-RAM (max. 3,6) und 720p Videos konnte ich vorher vergessen. Nun rennt der Balken nur so über den Bildschirm. Habe auch nur die beiden IPs in die Blacklist der Fritzbox eingetragen.

Freakyno1 1. Mai 2013 um 16:10 Uhr

So, nur mal kurz zur Info: Das eintragen in die Blacklist der Fritzbox alleine reicht nicht aus! Hat absolut keine Auswirkung, wer das nicht glauben möchte, sollte mal zb Google dort eintragen. Der Zugriff ist weiterhin möglich.
Die Filter/Listen müssen über die Kindersicherung den PC’s zugwiesen werden.
Allerdings besteht hier das Problem, dass die Blacklist der Fritzboxs keine IP-Adressbereiche unterstützt. Es müssten also alle IPs einzeln eingetragen werden.
Es können aber nur max. 500 Einträge hinzugefügt werden.
Ich denke mal, die zu blockierenden IP’s dürften weit mehr als 500 sein… ;-)

huebner herbert 1. Mai 2013 um 16:50 Uhr

bei mir geht da nichts, ist eh egal. youtube guck ich nicht. suche lieber ledige,nette dame,16-46, keine notgeilen. keine fake`s, für urlaub in diesfurth, pressath, trebgast. termin frei wählbar. huebner.passau@gmail.com

Matze.B 1. Mai 2013 um 17:37 Uhr

Muss von hier leider auch bestätigen:
– am ersten Tag schien der Tipp gut zu funktionieren; wobei ich hier nie allzu große Probleme mit Youtube habe – kann also sein dass der Eintrag in der Win 7 Firewall auch rein gar nichts bewirkt hat bei mir
– heute habe ich nun sogar Probleme bei 1080 Filmen, das Nachladen dauert recht lange und ich muss erst puffern

Torsten 1. Mai 2013 um 18:16 Uhr

@Andi

Der Tipp mit der statischen Routingtabelle(http://goo.gl/BBJGY) hat mit meiner FB 3390 nicht funktioniert. Es kommt die Meldung “Die IPv4-Adresse liegt nicht innerhalb des IPv4-Netzwerkes der FRITZ!Box.” Was ja auch so sein soll, wenn ich das richtig verstanden habe, aber ich kann die Konfiguration wegen der Fehlermeldung nicht abspeichern. Noch ein Tipp dazu?

Henning Sieh (@henningsieh) 1. Mai 2013 um 21:06 Uhr

In #Wiesbaden: Katastrophe! http://db.tt/Ggs27VeX Mit #Firewall-Regel kein Vergleich zu vorher – super!

Kubuntufrust 1. Mai 2013 um 21:24 Uhr

Zitat “Sollte dieser Trick klappen, dann wird er dies auch nur, wenn nicht die halbe Welt so agiert – denn dann sie die Server auch schnell direkt überlastet”

Scheint so. Normalerweise ist YT bei mir unmöglich zu nutzen (Drosselkom mit 16K!). Heute läufts aber perfekt. :)

Jasper 1. Mai 2013 um 22:24 Uhr

@sprechsucht
Danke, aber leider klappt es bei mir nicht. Bin Ubuntu-Anfänger und beim Einfügen der beiden kopierten Zeilen erscheint nur die erste, dann kommt eine Passwortabfrage. Ich gebe mein Passwort ein, drücke Return, dann steht da “Sorry, try again”. Mit 12.04 hatte ich das Passwort-Problem nicht, aber jetzt mit 13.04.

Weiß jemand alternativ wie man beim Router speedport w920v die IPs auf eine Blacklist setzen kann? Ich finde die Einstellungen nicht. Ich habe so gar nichts von meinem VDSL50, bei der youtube-Testseite nur 6,41! :(

sedisvakantist 1. Mai 2013 um 22:42 Uhr

Blacklist in der FritzBox einrichten:
1. Fritzbox im Browser aufrufen (in der Adresszeile entweder 192.168.178.1 oder http://fritz.box/ eintragen)
2. Im Menü (Spalte rechts) Menüpunkt “Internet” auswählen.
3. Unterpunkt “Filter” auswählen
4. Dort den Reiter “Listen” auswählen (alternativ kommt man dorthin natürlich auch direkt über das Verzeichnis “Inhalt” – “Listen”)
5. Dort “Liste gesperrter Internetseiten (Blacklist) bearbeiten” auswählen
6. Im dortigen Feld eintragen:
173.194.55.0/24
206.111.0.0/16
7. Mit OK bestätigen

In meinem Fall (Unitymedia 100Mbit) brachte das bei sehr zahlreichen, allerdings nicht bei allen HQ-Testvideos ganz erhebliche Geschwindigkeitsvorteile: Das sonst übliche Buffern sowie gelegentliches Ruckeln gibt es nunmehr nur noch äußerst selten.

Torsten 2. Mai 2013 um 08:12 Uhr

@ sedisvakantist

Ich ergänze mal, denn sonst bringt das Eintragen in die Blacklist gar nichts:

8. Menüpunkt “Internet” -> “Filter” aufrufen
9. Hier für jeden aufgeführten Computer die Kindersicherung mit der Blacklist zuordnen
10. mit OK bestätigen ;-)

Das bringt bei mir leider genau gar keinen Unterschied, es ist weiter sehr Tageszeit abhängig, ob YT läuft oder nicht.

Einer von 3% Power Usern 2. Mai 2013 um 11:05 Uhr

Ich schließe mich Torsten an, keine Verbesserung.

Konstantin 2. Mai 2013 um 14:50 Uhr

Funzt wunderbar – 2 Minuten 4K-Video -> https://www.youtube.com/watch?v=hVzL48VgYZQ (knapp über 370MB) – In knapp einer Minute geladen… Bisher ging das als 240p nicht mal in unter 5 Minuten – Telekom V-DSL25

ab 2. Mai 2013 um 18:42 Uhr

Klappt wunderbar mit der Blacklist vom Router. Besten Dank für diesen Beitrag!

Danke Caschy! 2. Mai 2013 um 19:14 Uhr

Für alle die eine ältere FritzBox wie ich haben und keine Software Firewall nutzen:

Den Windows Editor mit Adminrechten starten, die datei C:\Windows\System32\drivers\etc\hosts damit öffnen und folgendes einfügen:

127.0.0.1 173.194.55.0
127.0.0.1 206.111.0.0

Datei speichern, PC neustarten, Youtube geniesen :)

Wullewatz 2. Mai 2013 um 21:16 Uhr

Bei mir bringt es leider nichts, bin bei Drosseldum mit 16Mbit.
Habe mit und ohne Regel 4,09 bzw 5,35

Farlion 2. Mai 2013 um 22:07 Uhr

Unter Windows 7 hat es leider keine Auswirkungen. Videos hängen nach wie vor. Zwischen 16:00 und 0:00 Uhr ist Youtube für mich unbenutzbar.

Danke Caschy! 3. Mai 2013 um 10:52 Uhr

Ich muss mich korregieren.
Das eintragen in der Hosts Datei blockt keine IPs, sondern nur die Namensauflösung wird damit verändert.
Somit ist das ohne Wirkung

Ingrid 3. Mai 2013 um 12:17 Uhr

Zwei Fragen:

1.) Habe ich die IP-Range richtig verstanden?
Man muss den Eingang sperren
von 206.111.000.000 bis 206.111.255.255
und
von 173.194.055.000 bis 173.194.055.255
Habe das in der Comodo Firewall korrekt eingestellt?
Siehe Screenshot: http://hostr.co/cOt94zeSssj8

2.)
In der Comodo Firewall kann ich nur die Regel für den IP-Bereich
von 206.111.000.000 bis 206.111.255.255 erstellen.
Den IP-Bereich von 173.194.055.000 bis 173.194.055.255 nimmt Comodo nicht an bzw. wird die Regel sofort zurückgesetzt und deaktiviert.
Weshalb ist das so und wie bekomme ich die Blockierung dieses IP-Bereichs also in die Comodo Firewall?

Meine bisherige Erfahrung:
Mit der einen, anlegbaren Regel werden bei mir YouTube-Videos vorgeladen, wenn ich auf Pause klicke. Ohne die Regel wird nicht vorgeladen und während des Abspielens auch nur mit Unterbrechungen geladen. Die Regel hat also bei mir eine postive Wirkung.

Wenn mir jemand bei meinen 2 Fragen helfen könnte, wäre das super.

Helmut 3. Mai 2013 um 12:41 Uhr

Ich hab Telekom VDSL25 und ab 720p stottert die Wiedergabe. Sobald wie beschrieben die CDN-IP geblockt ist: Richtig schnelles Laden mit echten 25 Mbit/s. Danke für die Info, @caschy! Mir ist noch nicht ganz klar, ob das CDN absichtlich gedrosselt oder nur überlastet ist. Und wenn es gedrosselt sein sollte: Wer hat meinen Provider dazu autorisiert? Ich jedenfalls nicht.

Lieber spät als nie. :D 4. Mai 2013 um 13:48 Uhr

@ Ingrid

Zu blocken : 173.194.55.0 – 173.194.55.255 / 206.111.0.0 – 206.111.0.255

Nach Deinem Schema wäre das dann :

173.194.055.000 – 173.194.055.255 / 206.111.000.000 – 206.111.000.255

Laut Comodo-Hilfe geht das aber auch ohne das man immer drei Stellen in alle der vier Blöcke einträgt, also so wie bei meinem ersten Beispiel.

Hier ein Link zur Comodo-Hilfe (leider nur Englisch)

http://help.comodo.com/topic-8.....Zones.html

(Comodo Help My Blocked Network Zones suchen falls der Link nicht geht)

Konnte das jetzt nicht testen weil mein Uralt-PC nicht will, ist wohl die Grafikkarte kaputt.

Ich hoffe ich konnte helfen, viel Glück !

shad 4. Mai 2013 um 15:54 Uhr

Kann es sein, dass sich das Apple TV davon unbeeindruckt zeigt? Regeln eingetragen und dem ATV zugewiesen…schnelleres Laden kann ich NICHT bestätigen. PC selbst habe ich nicht getestet, da ich darauf quasi kein YT gucke.

Jasper 4. Mai 2013 um 15:58 Uhr

So, ich hab dass unter Ubuntu nicht hingekriegt. Aber ich nutze jetzt das FireFox-Addon Youtube Turbo und damit laufen die Full-HD-Videos endlich ohne zu Puffern!
Danke an die Tipp-Geber!!!

Baron von Merkwürden 4. Mai 2013 um 22:46 Uhr

Bei mir lief Youtube mit dem Firefox-AddOn garnicht mehr, habs gleich wieder runtergeschmissen.

Baron von Merkwürden der 2. 5. Mai 2013 um 11:18 Uhr

Hab das Youtube-AddOn nochmal getestet, mal scheinen die Videos schneller zu laden, meistens ist es genau wie vorher und seit ich das AddOn benutze spuckt Youtube oft Fehler aus. Für mich bringt also alles nicht wirklich was.

dakk 5. Mai 2013 um 17:30 Uhr

läuft jetzt merklich schneller! danke (bin bei mnet)

Max 5. Mai 2013 um 20:25 Uhr

Ich hab Telekom und noch nie irgendwelche Probleme mit YouTube gehabt und 1080p Videos starten auch ohne die Firewall-Regel in 2 sek. (Telekom – 16 MBit)

Andreas (@costunga) 12. Mai 2013 um 18:55 Uhr

Jemand eine Ahnung wie ich im Speedport W504V etwas in die Blacklist eintrage?

An Di Schwarz 13. Mai 2013 um 10:12 Uhr

Auf einen ASUS RT-AC66U eingetragen via Putty. [Jedes 2. Video lief nicht, KD 32]
iptables -I INPUT -s 173.194.55.0/24 -j REJECT
iptables -I INPUT -s 206.111.0.0/16 -j REJECT

Firmware MOD Tipp:
https://github.com/RMerl/asuswrt-merlin/wiki

Lucien 18. Mai 2013 um 11:14 Uhr

Haz bei mir auch soweit geklappt bei Windows 7 die Regel hinzuzufügen,muss da
mal länger testen,was komisch ist wenn ich ein Youtube Video rechtsklicke um
einen Speedtest zu machen,bekomme ich immer die Antwort:
“ir konnten keine Videowiedergaben von deinem Standort finden.”egal was ich
mache.

Manfred 1. Juni 2013 um 21:34 Uhr

Mac OSX 10.5.

funktioniert einwandfrei.

Kalle Kotschleck 25. Juni 2013 um 21:18 Uhr

YEP! Der Firewall-Trick funzt! Vielen Dank!

hamid harun 12. Dezember 2013 um 12:23 Uhr

ich bitte um verbässerung.danke

fhetto 22. Februar 2014 um 14:33 Uhr

geht nicht ruckelt immer noch

venti 15. März 2014 um 15:56 Uhr

Ich habe neben einem IPv4 auch einen IPv6 Zugang von der Telekom. Müsste ich nicht erstmal die IPv6-Adressen des CDN sperren? Wie lauten die denn?


Deine Meinung ist uns wichtig...

Kommentar verfassen

Du willst nichts verpassen?
Neben der E-Mail-Benachrichtigung habt ihr auch die Möglichkeit, den Feed dieses Beitrags zu abonnieren. Wer natürlich alles lesen möchte, der sollte den Hauptfeed abonnieren. Alternativ könnt ihr euch via E-Mail über alle neuen Beiträge hier im Blog informieren lassen. Einfach eure E-Mail-Adresse hier eingeben, dann bekommt ihr 1x täglich eine Zusammenstellung.